Potential delays when adding services
Incident Report for Websitebuilder
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 05, 2018 - 17:15 EDT
Investigating
We are currently investigating issue with orders; This could potentially cause delays when adding services onto accounts.
Posted 4 months ago. Apr 05, 2018 - 14:46 EDT